Symptoms
Applications open very slowly
Spinning wheel or not responding messages
Apps only open after waiting a long time
Likely causes
Low memory
Security scanning app files
Corrupt cache or add ins
Opening files from slow network or cloud folders
Disk nearly full
Fix
Restart the computer
Check CPU and memory usage
Test opening a blank file
Copy files locally and try again
Disable add ins
Reinstall the affected app
When to contact IT
Multiple users affected
Business critical app broken